Unable to run subgraph analysis

Home Forums General Help Unable to run subgraph analysis

This topic contains 0 replies, has 1 voice, and was last updated by  johnsojp 3 weeks, 3 days ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #21926 Reply

    johnsojp
    Participant

    Hello BRAPH team,
    I can’t seem to run subgraph analyses on my data and I am unsure why. I set up a weighted undirected graph with pearson correlations and I am including negative correlations (however, I have also tried setting negatives to zero and I get the same error described below when I try to run subgraph analysis). Just in case it’s relevant, I entered my subject-level data as correlation matrices (as described in another forum post) rather than timeseries data.

    I set my community structure based on one group of participants by entering the community structure window, selecting Newman algorithm, gamma = 1, and clicking “Calculate”; then I checked “Fixed structure”, clicked “Set”, and closed the community structure window. I next opened the Subgraph analysis window, selected the first module (module1), clicked “set” and then “start analysis”, which returned the following error in matlab:

    Matrix dimensions must agree.

    Error in GUIfMRIGraphAnalysis/update_matrix (line 714)
    A = A+ga.getA(indices(i));

    Error in GUIfMRIGraphAnalysis/setup (line 1204)
    update_matrix()

    Error in GUIfMRIGraphAnalysis (line 1188)
    setup()

    Error in GUIfMRIGraphAnalysisSubgraph/cb_menu_ga (line 575)
    GUIfMRIGraphAnalysis(subgraph)

    Error using GUIfMRIGraphAnalysis/cb_calc_sub (line 483)
    Error while evaluating UIControl Callback

    Can anyone provide some guidance on what’s going on here and how I can fix it?

    Thank you very much!

    Jeff

Viewing 1 post (of 1 total)
Reply To: Unable to run subgraph analysis
Your information: